Usando lectores de tarjetas inteligentes (DNIe) en Linux [C3PO, GEMPLUS, BIT4ID]

17 Mar 2010

Compartelo:Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

El problema a la hora de utilizar lectores de tarjetas inteligentes en Linux normalmente es la existencia de drivers, ya que en ocasiones los fabricantes sólo se preocupan por la versión Windows, afortunadamente esta situación ha cambiado y actualmente es muchísimo más fácil hacer uso de estos lectores en Linux.

Extraído de las prueba de compatibilidad que en su día realizamos para comprobar el comportamiento de Viafirma con estos lectores , vamos a hacer un pequeño repaso por fabricante sobre cómo instalarlos:

Instalación del driver para un lector  Bit4Id, C3PO y GEMPLUS.
La mayoría de las distribuciones (incluida Ubuntu) ya disponen de los drivers empaquetados, por lo que sólo será necesario la instalación de estos nuevos paquetes (por ejemplo usando synaptic en el caso de Ubuntu). En caso de que no existan paquetes para su versión de Linux, el fabricante proporciona los fuentes de los drivers en formato tar.gz

Los paquetes que deberemos instalar son: libccid (Paquete de driver compatible con la mayoría de los lectores) y libacr38u ( Driver para el miniLector Essential y otros lectores con chip ACR38U) haciendo uso del gestor de Paquetes.

Instalar lector driver bit4id ubuntu

Si no deseamos utilizar el instalador visual, desde el terminal podemos ejecutar:

sudo apt-get install libccid libacr38u

Instalar la libreŕia para tarjetas inteligente (OpenSC)

Al igual que en el apartado anterior, es posible realizar esta instalación desde el instalador visual o desde el terminal ejecutando: sudo apt-get install opensc

Instalar los drivers para el DNIe.

En el caso particular del DNIe, también será necesario la instalación del paquete opensc-dnie, que aunque está disponible para su descarga en http://www.dnielectronico.es/descargas/PKCS11_para_Sistemas_Unix/index.html.

Instalar dnie

Probamos nuestro nuestro lector con Viafirma

Para ello, con el DNIe ya introducido en nuestro lector, accedemos con Safai o Firefox a la demo de Viafirma .

Usando el dnie en MacOS X

Problemas conocidos

Debido a un problema en la librería OpenSC no es posible que dos aplicaciones hagan uso a la vez del lector de tarjetas, por lo que si en Firefox se encuentra configurado como módulo el driver del DNIe no será posible desde el Applet de Viafirma.

http://www.opensc-project.org/opensc/ticket/134

Comandos avanzados

Para comprobar que el lector es reconocido por el sistema podemos instalar las librerías pcsc-tools

sudo apt-get install pcsc-tools

y ejecutar el comando pcsc_scan para detectar los lectores instalados en el sistema.

Post relacionados

Compartelo:Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

Sin comentarios

Dejar un comentario

*