¿Qué drivers necesito para usar el DNIe?

11 Jun 2013

Compartelo:Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

Es muy común, cuando se quiere empezar a sacar partido del DNI electrónico, el encontrarte con miles de problemas, desde el desconocimiento del PIN, hasta la casi desintegración del chip en algunos casos. Sin duda, todos ellos problemas que hacen muy cuestionable la usabilidad del DNIe.

En el caso de no conocer el PIN de nuestro DNIe, tenemos que pasarnos por la comisaría de policía más cercana he introducir una nueva contraseña para nuestro DNIe desde uno de los PAD de acceso público, donde mediante nuestra huella dactilar nos permitirá cambiar nuestra contraseña o renovar los certificados en el caso de que estén caducados.

Para poder hacer uso del DNI electrónico se requiere primeramente que se lleve a cabo la instalación de los controladores que hacen posible la comunicación con el mismo.

En el caso de Windows 7 y Windows 8, el sistema operativo ya dispone de un servicio de actualización de Microsoft Windows Update, dónde se encuentra disponible la nueva versión del driver del DNIe. Este nuevo driver permite al DNIe trabajar como dispositivo plug&play, ya que se instala de forma automática una vez insertado el mismo en un lector compatible.

Este driver, basado en la nueva arquitectura “Smart Card Mini-Driver” (conocida también como “Smart Card Module”) de Microsoft, funciona en Internet Explorer y en Google Chrome. Mozilla Firefox, al utilizar la arquitectura PKCS#11, seguirá necesitando la instalación del módulo criptográfico.

Por lo tanto, en un ordenador con sistema operativo Windows 7 y 8, únicamente habrá que introducir la tarjeta DNIe en el lector y el Sistema Operativo instalará el driver de forma rápida y automática.

En los sistemas operativos basados en UNIX como Ubuntu o OSX, es necesario disponer de en un módulo criptográfico PKCS#11 (Public Key Cryptography Standard Number 11) encargado de interpretar las comunicaciones con la tarjeta. Para lo que necesitamos instalar OpenSC / OpenDNIe en nuestro equipo. Podemos seguir las indicaciones de cómo hacerlo en el siguiente enlace http://www.dnielectronico.es/descargas/PKCS11_para_Sistemas_Unix/index.htm

Por otro lado, si queremos hacer uso del DNI electrónico en un dispositivo móvil, necesitamos de una aplicación nativa que disponga de un módulo criptográfico PKCS#11 (Public Key Cryptography Standard Number 11) encargado de interpretar las comunicaciones con la tarjeta, cómo es el caso de nuestra app viafirma mobile, la cual además, dispone de una API que permite interactuar con el DNIe desde una tercera aplicación nativa o un navegador web.

Por último, recordaros que podéis descargar los SDKs gratuitos para integrar vuestras apps con nuestra plataforma de firmas en nuestro portal para desarrolladores.

Espero que os haya sido útil la información.

Post relacionados

Compartelo:Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0

Sin comentarios

Dejar un comentario

*